Home after op with a catheter!

Posted , 6 users are following.

This discussion has been locked due to a period of inactivity. Start a new discussion

Hi ladies

i had my op on Thursday, posterior repair and vaginal vault suspension. I also have a cystocele but they did not repair it as I would have had too much work done and a lot of scar tissue. They did find a cyst on my bladder though which they removed.

They removed the vaginal pack and catheter yesterday but I could not go to toilet. Drank lots, kept trying but it wasn't happening so they have had to put the catheter back in. Told me I would have it a week and go back next Friday to have the catheter removed and see how I go.

anyone else had this and did your bladders function properly second time round?

Any advice would be great please!

Lorraine

0 likes, 7 replies

Report

7 Replies

  • Posted

    I haven't lorraine but a friend of mine did just a few months ago. When it was removed she passed urine without any problems. Apparently it's quite common. 
    Report
  • Posted

    Lorraine, I THINK it can be a problem from bruising?  I didn't have a problem when mine was done but do remember someone saying that it was possible.  Hope you're fine this time round:-)
    Report
  • Posted

    I also was unable to urinate but I had to self cath which was interesting! And very stressful. After about 4-5 days I was able to urinate on my own without a catheter. I was terrified that I would have to cath forever but as the previous person said, it's quite normal for the bladder to not function as well for a little while after these procedures. Don't panic you'll be fine soon!
    Report
  • Posted

    Thanks everyone for the replies. I'm just frustrated cos I wanted to be fully on the mend. This forum has been brilliant for preparing me for everything. I went into the op having read so much from you guys beforehand.

    just want to get back to normal now. Only been 2 days I know but I'm much rougher than I thought I'd be! X

    Report
  • Posted

    I don't know if this will help but I had a catheter during my first labour and couldn't pee afterwards due to bruising.  My sister helped me out by taking me to the loo and turning all the taps on.  I filled about 2 jugs!
    Report
  • Posted

    Have you tried passing urine by standing with a jug. I have voiding problems due to a mesh TVT and find that I have to stand using a jug.
    Report
  • Posted

    I'm back to hospital 9am tomorrow to get the catheter removed. 

    Hooe everything works as it should, I am not coming home with this thing again.

    its disgusting and makes me feel ill. Think I may have a urine infection. The urine has a strong odour and little blood clots are coming out of the bag too.

    urrgh, I hate all this!!!! 

    Report

Join this discussion or start a new one?

New discussion

Report as inappropriate

Thanks for your help!

We want the forums to be a useful resource for our users but it is important to remember that the forums are not moderated or reviewed by doctors and so you should not rely on opinions or advice given by other users in respect of any healthcare matters. Always speak to your doctor before acting and in cases of emergency seek appropriate medical assistance immediately. Use of the forums is subject to our Terms of Use and Privacy Policy and steps will be taken to remove posts identified as being in breach of those terms.

newnav-down newnav-up