Vaginal Discharge

Posted , 3 users are following.

Help-I have had two hysteroscopys and one CT scan to ascertain what is

causing the brown vaginal discharge which I have been experiencing since

January 2015 - the last hysteroscopy said it was due to atrophic vaginitas

and prescribed vagifem which I have been using for the last three weeks

but still have the discharge saw my doctor this morning who is mystified but

said to continue using vagifem and she will see me in three weeks when course is finished - I thought it may be caused by a prolapse but doctors said not - has anyone else experience this

1 like, 5 replies

Report / Delete

5 Replies

  • Posted

    Hi shelia

    i am post meno aged 50 and have a very mild uterus prolapse 

    also dryness and i too use vaginal estrogen called Ovestin Estriol in Ovules and cream form.

    i have never had any bleeding or brown discharge with my mild prolapse 

    jay x 

    Report / Delete Reply
    • Posted

      Hi Jayneejay,

      Thanks for your reply - I have been diagnosed with a mild to moderate

      cystocele but from what you and the doctor have said this is not causing

      the problem - I forgot to mention my age I am 69

      Sheila

      x

      Report / Delete Reply
    • Posted

      Hi sheila 

      oh yours is bladder then, mines the uterus ..

      i think this must be yours below .. Some brief info 

      Anterior prolapse, also known as a cystocele (SIS-toe-seel), occurs when the supportive tissue between a woman's bladder and vaginal wall weakens and stretches, allowing the bladder to bulge into the vagina. Anterior prolapse is also called a prolapsed bladder.

      jay x

      Report / Delete Reply
  • Posted

    Dear sheila,

    i have had the same for 3 years. If you get any answers please share. I have gone to 3 gyns and tried many things without reliëf. My Dr. says i am not the only patient with this complaint. This doesn't resolve anything or make me trust in medical care when it comes to womens health!.

    Report / Delete Reply
    • Posted

      Hi Ginnerae,

      Its nice to know you are not alone - my doctor is mystified and does

      not know what is causing problem - during my 1st hysteroscopy they took

      tissue sample and result was benign endometrial poly - 2nd hysteroscopy which  was done under general anasthetic they found nothing - which does not fill me with confidence o nly that I had atrophic vaginitic and prescribed hr I am due to see doctor again in threes who said if I still had discharge she

      would refer me back again to hospital -  if I get any answers

      I will contact you

      Sheila

       

      Report / Delete Reply

Join this discussion or start a new one?

New discussion Reply

Report or request deletion

Thanks for your help!

We want the forums to be a useful resource for our users but it is important to remember that the forums are not moderated or reviewed by doctors and so you should not rely on opinions or advice given by other users in respect of any healthcare matters. Always speak to your doctor before acting and in cases of emergency seek appropriate medical assistance immediately. Use of the forums is subject to our Terms of Use and Privacy Policy and steps will be taken to remove posts identified as being in breach of those terms.

newnav-down newnav-up