Bleeding on Premphase (after 4 years no periods)

Posted , 2 users are following.

I went into early menopause following chemotherapy. Now at 49 I have not had a period or any bleeding for over 4 years. To treat osteopenia, I kust started hrt and just completed my first cycle of premphase (so Im now almost finishing 5th week of tablets). But since 4 days I'm bleeding heavily and cramping. This surprises me as I haven't bled at all in four years and would have thought my gynacologist would have told me to expect this. Otherwise no symptoms.

Can anyone tell me: Is this normal?

Thanks!

0 likes, 2 replies

Report

2 Replies

  • Posted

    hi rose i have been on hrt fir many years . at age 52 now 57 changed combination i bleed all the time i have regular scan it has settled down now and can take 6-12 month just ask for them to refer you to check lining womb for peace of mind , but it is very common and it your body getting used to flutuating hormones and finding what hrt suit you . good luck .

    Report Reply

Report as inappropriate

Thanks for your help!

We want the forums to be a useful resource for our users but it is important to remember that the forums are not moderated or reviewed by doctors and so you should not rely on opinions or advice given by other users in respect of any healthcare matters. Always speak to your doctor before acting and in cases of emergency seek appropriate medical assistance immediately. Use of the forums is subject to our Terms of Use and Privacy Policy and steps will be taken to remove posts identified as being in breach of those terms.

newnav-down newnav-up