Difficulty weeing?

Posted , 5 users are following.

Hi all 

Has anyone found it difficult to go to the toliet because of your fibroids?  I sometimes have to strain a bit to make myself 'go' (sorry for this) also, i have to move about abit to finish going. - has this happen to any of you?

Also, (really really sorry for this) does anyone suffer from having discoloured discharge also?  this happen on a daily basis.

Sorry for asking these questions.

Lou x 

0 likes, 7 replies

Report / Delete

7 Replies

  • Posted

    Hi Lou, not really had that problem, I seem to have more of an incontinence issue if rushing about with a full bladder!

    Yes I had the same continuous light pinkish discharge in between bouts of sudden heavy bleeding. Only taking Esmya stopped that, took about 6 weeks before I was confident to go out without wearing a pad.

    Report / Delete Reply
  • Posted

    Hi Briggsy,

    Ive had trouble weeing but my problem was going more frequently, but it depends on where the fibroids are situated, if they grow and on in the right area it can put pressure on the bladder.

    As for the discharge i suffered with it several times and still do its like a yellow colour but the doctor said it was just due to hormonal changes in the body, and it can also be due to what you wash in.

    Dont ever be sorry for asking questions like this, its helps a lot of people hun who have the same problem and are too shy to ask, 

    I really hope you get sorted out really soon xx

    Report / Delete Reply
  • Posted

    Hi Briggsy,

    I have the same problem when weeing,i have to move move(i believe u understd it) n i tend to think its the fibrods broking the way,its annoying,but i try taking alots of water n pumpkins soups,fibres to have it loose...

    As for discharge,i have no problem so far but i find that am spotting(bleed) when am taking iron tablets!! (I mean if i start periods when am taking iron tablets,it still continues for over 2wks,horrible!!!

    Courage girl...

    Report / Delete Reply
  • Posted

    Hi there Briggsy,

    YES!! This is exactly the problem I started having about a year ago. Sometimes I'd have to strain so hard that I thought I was going to pop a vein in my head. The problem wasn't every time I went to the loo, but the episodes did get closer together. About five months after this started, I had an instance where I could not pee at all, despite having a very full bladder. I ended up in A&E with acute urinary retention. This happened several more times and I was taught how to self-catheterize. I sobbed hysterically at the thought of this, but if you've ever waited for hours in A&E with 1800ml of urine in your bladder, you'll appreciate the ability to take care of it at home.

    This is actually what led to the discovery of my fibroids. My symptoms were almost al bladder related -- heavy periods weren't so much a problem. I've just passed the seven-week UFE date and I have not seen a whole lot of improvement bladder-wise. I've even had more instances of acute urinary retention, although the IR said this is common for the first month after the procedure. I'm trying to be patient, as I know the fibroid is shrinking, but it must be in a position that greatly irritates my bladder.

    You should get treatment asap, if you haven't already, as the retention will only get worse as the fibroid grows.

    Take care!

    Report / Delete Reply

Join this discussion or start a new one?

New discussion Reply

Report or request deletion

Thanks for your help!

We want the forums to be a useful resource for our users but it is important to remember that the forums are not moderated or reviewed by doctors and so you should not rely on opinions or advice given by other users in respect of any healthcare matters. Always speak to your doctor before acting and in cases of emergency seek appropriate medical assistance immediately. Use of the forums is subject to our Terms of Use and Privacy Policy and steps will be taken to remove posts identified as being in breach of those terms.

newnav-down newnav-up