Uti/kidney infection

Posted , 3 users are following.

This discussion has been locked due to a period of inactivity. Start a new discussion

Hi. Im a 39 yr old male. I've had uti's since I was young. I've had ultrasound scans and a camera to find nothing. The only suggestion maybe a kinked tube somewhere. Although that diagnosis was 25 yrs ago. I shall be going back to my doctors for further investigation.

Last Friday night I went to the toilet in the early hours. It felt quite uncomfortable to urinate but the give away sign for me was the foul smell of my urine. I thought "I know what this is"!! I didn't feel unwell physically though.

The Saturday morning I took myself off to my local hospital minor injuries unit for antibiotics. I was given a 5 day course of trimethoprim 200mg.

I had diarrhoea twice Saturday morning. Saturday afternoon the fever kicked in but not too serious. My worst day was Sunday. Severe back pain on both flanks and at the bottom of my back. Sunday night I woke in a raging sweat. Soaking wet through but not feeling ill. Monday I thought I was well on the way to recovery. No back pain until I got up that is! No signs of feeling unwell except feeling a little lathargic. Monday evening a yet again had diarrhoea twice and my lower back pain was terrible when I got up. Monday night I again woke in a terrible sweat. The thing is I don't feel unwell. Going to the toilet is getting easier but Tuesday is day 4 of 5 and it should have cleared up by now. Do I need to panic and go back to my doctors or ride it out and hope the last 4 pills do the job? I'm very concerned that my kidneys are getting damaged which will lead to further complications. Any help??

0 likes, 6 replies

Report

6 Replies

  • Posted

    I had a UTI , fever, etc. Was going to ride it out. Then nausea set in. Decided to go to docs. Good thing i did. Fever jumped alot between 5 am and noon. If I waited I think I would have been in trouble. Was in a hospital bed by 12:30. Took 5 days on anti biotics to get rid of it. Doc said if I waited any longer it may have made it to my blood stream. I talked to a guy i know a month later. He got one waited.to long. Was in hospital 2 weeks, twice. Got in his blood. They had trouble getting rid of it. I would atleast call someone if I was you. Won't hurt or cost anything to talk to someone.

    Report
    • Posted

      Hi there. Thanks for your reply. The thing is, I went to the hospital as soon as I realised to get antibiotics. I don't feel ill as such. A little weak yes but not ill. I've got twinges in my back but it's the raging sweats and diarrhoea I've still got. I'm going to ring the docs this morning.

      Report
    • Posted

      I was on antibiotics. Thought they was working. Infection was resistant. They didn't do a thing. Took a course of 3 different antibiotics to kill it cause I waited and other one didn't help. 2 IV ones. One in pill form for 10 days after a week in hospital. The IV meds was 1 of them every 8 hours. Other was every 12 hours. The every 12 hour med took 3 and a half hours to run. They were so strong they blew all the veins out in both arms by the time they were done. Bruised from the elbows down. Am a healthy 53 year old. No vein problems. The meds made my temp no up and down. I would wake up in the middle of the night soaked in sweat. Would call nurse to change sheets bring me a dry gown. Only good thing was nurses were super nice people, food was real good. Room was private cause I had a infection so was quiet and very relaxing. Lol

      Report
  • Posted

    Hi There, Did they do a culture to see what bacteria it is?  Some antibiotics will not work for certain bacteria.  Also the diareha could be a side effect from the antibiotics.  I have had fevers, diareha and sweats from the antibioti itself.  I would get a urine culture to see what strain of bacteria is in your urine.  ack pains are tell tale signs of UTI, foul urine also so I would get it checked out sooner than later smile

    Report
    • Posted

      Hi Linda. Yes, been to the docs this morning. Had 4 BP tests. 3 were up and 1 was ok. Urine clear on the swab test but can't give any other antibiotics until the sample has come back from the lab. Temp is ok but continually sweating. Going back for bloods tomorrow morning.

      Report

Join this discussion or start a new one?

New discussion

Report as inappropriate

Thanks for your help!

We want the forums to be a useful resource for our users but it is important to remember that the forums are not moderated or reviewed by doctors and so you should not rely on opinions or advice given by other users in respect of any healthcare matters. Always speak to your doctor before acting and in cases of emergency seek appropriate medical assistance immediately. Use of the forums is subject to our Terms of Use and Privacy Policy and steps will be taken to remove posts identified as being in breach of those terms.

newnav-down newnav-up