Red painless bumps on my penis and inflammation of the frenulum

Posted , 4 users are following.

HI. Some 2 weeks ago i had sex with my gf who was under treatment for a urinary infection that was cause by bacteria.The sexual contact was with a condom. Some hours later i've started having burning sensation when urinating and testicular pain. I've taken antibiotics for urinary infection, Nolicin and a supplement called Urinal Aktiv.After 5 days the pain left me but now i'm having these red bumps on my penis and my frenulum it's slithy inflamated. Also there's a red line just below my frenulum that looks like a scratch.What's the cause of that ? Maybe a balanitis staphylococcus ? Anyway i've added some pictures.I'm really afraid of HPV-2 but I don't think it's the case here. Any thoughts ?

0 likes, 7 replies

Report / Delete

7 Replies

  • Posted

    I think the antibiotics may have caused you to have balanitis, but fungal rather than bacterial.  The red line you mention may be part of your perineal raphe (which goes from the frenulum down your penile shaft and scrotum, across the perineum all the way to the anus.  It may always have  been there, but you're only noticing it now because the infection has made it a slightly different colour.

    It certainly doesn't look like HPV or HSV-2.

    Personally, I wouldn't see a doctor for that, but if you do, please let us know what they say.

    If it is balanitis, then these links may help:

    https://patient.info/health/balanitis-leaflet

    https://patient.info/doctor/balanitis-pro  ;

    (written for doctors)

    Washing (with water, no soap) daily, and taking a leak and washing after masturbation or sex will probably help, and you could also try Canesten cream or Daktarin cream.  Loose fitting cotton underwear may help, and some sites recommend washing underwear with non-biological washing powder or liquid.

    Report / Delete Reply
  • Posted

    Thank you for the reply.In the last 12h I had different symptoms.I'm urinating frequently and very little.So i went to the doctors and they said it's very probable a UTI. So now I'm waiting the results from the lab to see what bacteria it's in my urethra.As for meds they gave me no antibiotics until results came, just some cranberry based meds and rowatinex. Anyway I'm hoping I can take a leak in the future normally not like just a few jets.

    Report / Delete Reply
    • Posted

      I thought your original symptoms had cleared up, but if they're back, then you'll probably need more antibiotics if they can identify what you have (sometimes they can't).

      Some of the links here may help:

      https://patient.info/search.asp?searchterm=urethritis

      It still seems likely that the symptoms you described in your original post are caused by the antibiotics though.  They (the symptoms) may not be directly connected to the actual infection.

      Weren't you tested for chlamydia and other STIs when you first saw a doctor??

      Report / Delete Reply
  • Posted

    Which test did they carry on you for bacterial detection? 
    Report / Delete Reply
  • Posted

    Urine culture with antibiogram. In my mind there are 2 options either it's a UTI from a bacteria or Chlamydia.Now I'll just wait for results and go to the doc for treatment

    Report / Delete Reply
  • Posted

    This is starting to become funny.My results came in and they're all negative.

    Report / Delete Reply

Join this discussion or start a new one?

New discussion Reply

Report or request deletion

Thanks for your help!

We want the forums to be a useful resource for our users but it is important to remember that the forums are not moderated or reviewed by doctors and so you should not rely on opinions or advice given by other users in respect of any healthcare matters. Always speak to your doctor before acting and in cases of emergency seek appropriate medical assistance immediately. Use of the forums is subject to our Terms of Use and Privacy Policy and steps will be taken to remove posts identified as being in breach of those terms.

newnav-down newnav-up